Software Downloads

eLearning Space Software for Mac

You will need Java and a pdf file reader in order to successfully use eLearning Space. Java and Preview (a pdf file reader) are part of the Macintosh Operating System.

While a range of Java versions are supported by Blackboard we recommend 1.5.0_07 which is not the latest so please turn off Java Software Updates. However, Kronos users please contact your IT Support before upgrading, as Kronos has particular Java requirements.

The following plugins may also be necessary if movies and animations have been used as part of your online subject. Please check with your lecturer before you download these plugins.

  • Windows Media player
  • Real player
  • QuickTime
  • Shockwave
  • Flash player
Last reviewed: 22 April, 2016